Some customers might experience problems with sign-in
Incident Report for Integromat
Resolved
This incident has been resolved.
Posted Apr 03, 2022 - 17:11 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2022 - 16:42 CEST
Investigating
We are currently investigating this issue.
Posted Apr 03, 2022 - 16:00 CEST
This incident affected: Website.