Login issues
Incident Report for Integromat
Resolved
This incident has been resolved.
Posted Aug 21, 2020 - 06:23 CEST
Update
We are continuing to investigate this issue.
Posted Aug 21, 2020 - 06:01 CEST
Investigating
We are currently investigating issues with a login.
Posted Aug 21, 2020 - 05:30 CEST
This incident affected: Website.